Lentidão no envio e recebimento de mensagens
Incident Report for OmniChat
Postmortem

O que aconteceu?

Entre 11:05 de 22 de novembro de 2022 e 11:30 de 22 de novembro de 2022, a plataforma da OmniChat apresentou um problema que causou instabilidade na plataforma.

 

Causa Raiz:

A Engenharia da OmniChat identificou o problema em um micro serviço interno da OmniChat, responsável por intermediar requisições para um de nossos bancos de dados, estava demandando muitos recursos, gerando lentidão de todos os serviços que têm dependência do mesmo. 

 

Resolução e prevenção:

A Engenharia da OmniChat identificou o problema às 11h05 do dia 22 de novembro, através de alarmes de monitoramento. Desde então a engenharia da OmniChat trabalhou para isolar e atenuar o problema. 

Foram executadas análises minuciosas em todos os serviços que apresentaram lentidão, a fim de isolar a causa raiz do problema.

Às 11:30h do dia 22 de novembro a engenharia da OmniChat encontrou a causa raiz do problema e executou o procedimento de manutenção emergencial para que o problema fosse sanado.

 

Para evitar a recorrência do problema, agir de forma ativa e mais assertiva, a engenharia está tomando as seguintes ações:

 

  • Incluir filtros que limitam a demanda por recursos de banco de dados, de forma a não permitir que eventos como esse, possam prejudicar o funcionamento integral do serviço.

 

A OmniChat está comprometida em melhorar continuamente nossa tecnologia e operações para evitar interrupções e degradações do serviço. Agradecemos sua paciência e pedimos desculpas novamente por qualquer impacto em sua organização.

Posted Nov 25, 2022 - 12:44 GMT-03:00

Resolved
O problema com a plataforma foi resolvido. Lamentamos o transtorno e agradecemos a paciência. Tenha certeza de que a confiabilidade do sistema é uma prioridade para a Omnichat, estamos fazendo aprimoramentos contínuos para tornar a sua experiência cada vez melhor. O postmortem será publicado nos próximos dias com maiores detalhes sobre o incidente.
Posted Nov 22, 2022 - 17:20 GMT-03:00
Monitoring
O problema foi solucionado e a plataforma está operacional, estamos monitorando a correção efetuada.
Posted Nov 22, 2022 - 12:07 GMT-03:00
Identified
Identificamos a possível causa do problema, estamos efetuando alguns testes em breve a correção será refletida para todos os clientes.
Posted Nov 22, 2022 - 11:29 GMT-03:00
Investigating
Estamos investigando relatos de um problema com a plataforma. Forneceremos mais informações em breve. Os usuários afetados enfrentam lentidão no envio de mensagens
Posted Nov 22, 2022 - 11:13 GMT-03:00
This incident affected: Chat Platforms (Web Chat, WhatsApp Business API) and App - https://app.omni.chat, Bot.