Lentidão na plataforma
Incident Report for OmniChat
Postmortem

O que aconteceu?

Entre 08:30 do dia 02 de junho de 2021 e 09:53 do mesmo dia, a plataforma da OmniChat apresentou um problema que causou lentidão no uso da plataforma de modo geral.

Causa Raiz:

A Engenharia da OmniChat identificou uma inconsistência no processo de escala de recursos em um dos micro serviços responsáveis pela tradução de mensagens na plataforma, que resultou em falta de recursos para o micro serviço e consequentemente lentidão na plataforma.

Essa inconsistência foi causada por uma atualização de infraestrutura.

Resolução e prevenção:

Às 8:30 a Engenharia da OmniChat iniciou as análises para isolar e atenuar o problema e às 08:49 tomou conhecimento de relatos de clientes sobre a lentidão apresentada na plataforma.

Foram executadas análises em vários processos da plataforma até que fosse possível  identificar e isolar a causa raiz.

‌Às 09:53h do dia 02 de junho a engenharia da OmniChat encontrou o problema no sistema de escala de recursos e executou uma correção manual no serviço para que o problema fosse sanado, porém o mesmo serviço voltou a apresentar problemas às 11:00 o que levou o time novamente a efetuar correções desta vez de forma a persistir a correção, o monitoramento posterior mostrou que a correção efetuada se tornou efetiva e estabilizou a plataforma às 11:30.

Para evitar a recorrência do problema, agir de forma ativa e mais assertiva, a engenharia está tomando as seguintes ações:

  • Serão colocados critérios adicionais para alterações em recursos e escala de infraestrutura antes de uma aprovação para produção.

     

  • Serão implementados novos alarmes para detecção antecipada de falhas na resposta dos micro serviços.

A OmniChat está comprometida em melhorar continuamente nossa tecnologia e operações para evitar interrupções e degradações do serviço. Agradecemos sua paciência e pedimos desculpas novamente por qualquer impacto em sua organização.

Posted Jun 02, 2021 - 20:23 GMT-03:00

Resolved
This incident has been resolved.
Posted Jun 02, 2021 - 09:53 GMT-03:00
Update
O problema com a plataforma foi resolvido. Lamentamos o transtorno e agradecemos a paciência. Tenha certeza de que a confiabilidade do sistema é uma prioridade para a Omnichat, estamos fazendo aprimoramentos contínuos para tornar a sua experiência cada vez melhor. O postmortem será publicado nos próximos dias com maiores detalhes sobre o incidente.
Posted Jun 02, 2021 - 09:49 GMT-03:00
Investigating
Estamos investigando relatos de um problema com a plataforma. Forneceremos mais informações em breve. Os usuários afetados enfrentam lentidão no uso da plataforma.
Posted Jun 02, 2021 - 09:15 GMT-03:00
This incident affected: Payment gateways (Wirecard integration, MundiPagg Integration), App - https://app.omni.chat, and Chat Platforms (Web Chat).